That's certainly easy to understand. (One possible alternative could be ianaName↔︎ianaCharsetName, whatwgName↔︎whatwgEncodingName...redundant?) I would suggest even shorter labels: public init?(iana: String) public init?(whatwg: String) There’s no reason here to repeat “encoding” (or “charset” in IANA parlance, which at worst could be conf...